View Issue Details

IDProjectCategoryView StatusLast Update
0000089WolfAdminSetup & Configurationpublic2019-01-17 11:12
ReporterspyhawkAssigned ToTimo 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.0 
Target Version1.2.1Fixed in Version1.2.1 
Summary0000089: Removing extra config files crashes etlded
DescriptionI removed the [sprees] section from the main wolfadmin.toml config file, which disables sprees.

I then tried to remove the now useless sprees.toml entirely, but etlded crashes without warning. I'd expect a nicer way to handle that non critical missing file.

Tested on windows.
Steps To Reproduce* remove the [sprees] section from the main wolfadmin.toml config file
* remove the now useless sprees.toml files
* launch elded
Additional InformationSprees display is a cancerous feature.
TagsNo tags attached.
ModLegacy
Mod versionv2.75-2327
Standaloneyes

Activities

Timo

2019-01-17 11:06

administrator   ~0000118

Actually removing the [sprees] section reverts it to default, which sets the sprees file setting back to "sprees.toml". This caused the module to load the file nevertheless, resulting in a crash because this particular file was not checked for existence. Pushing a fix for this.

Timo

2019-01-17 11:08

administrator   ~0000119

Fixed in changeset 415835c72366048b812339bc63b1ba67ddbb3a05.

Related Changesets

WolfAdmin: develop/1.2.1 415835c7

2019-01-17 11:12:48

Timo

Details Diff
Check whether sprees file exist (fixes 0000089) Affected Issues
0000089
mod - luascripts/wolfadmin/game/sprees.lua Diff File

Issue History

Date Modified Username Field Change
2019-01-04 22:09 spyhawk New Issue
2019-01-17 10:21 Timo Standalone no => yes
2019-01-17 10:46 Timo Target Version => 1.2.1
2019-01-17 11:06 Timo Note Added: 0000118
2019-01-17 11:08 Timo Changeset attached => WolfAdmin develop/1.2.1 415835c7
2019-01-17 11:08 Timo Note Added: 0000119
2019-01-17 11:08 Timo Assigned To => Timo
2019-01-17 11:08 Timo Status new => resolved
2019-01-17 11:08 Timo Resolution open => fixed
2019-01-17 11:12 Timo Fixed in Version => 1.2.1