View Issue Details

IDProjectCategoryView StatusLast Update
0000069WolfAdminGeneralpublic2019-01-31 18:28
ReporterTimoAssigned ToTimo 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target Version1.2.0Fixed in Version1.2.0 
Summary0000069: Provide alternative to shrubbot
DescriptionIn standalone mode, there should be some administration of player levels and access to functionality (be it commands or other features).

Proposal:
 * ACL-based system in which levels are assigned different roles which determine what players having that level are allowed to do
 * (optional) implement cache for MySQL database
TagsNo tags attached.
ModN/A
Mod version
Standaloneno

Relationships

related to 0000062 resolvedTimo Provide basic admin commands 
related to 0000097 new Make an easier interface for new commands 
related to 0000092 new Implement team chat spy 
child of 0000061 resolvedTimo Standalone mode 

Activities

There are no notes attached to this issue.

Related Changesets

WolfAdmin: develop/1.2.0 8977ba41

2017-01-13 18:59:14

Timo

Details Diff
Implemented basic ACL functionality (issue 0000069) Affected Issues
0000069
mod - database/new/wolfadmin_sqlite.sql Diff File
mod - luascripts/auth/acl.lua Diff File
mod - luascripts/commands/admin/setlevel.lua Diff File
mod - luascripts/db/sqlite3.lua Diff File

WolfAdmin: develop/1.2.0 702ed274

2017-01-20 19:53:55

Timo

Details Diff
Added acl command for server console (refs 0000062, 0000069) Affected Issues
0000062, 0000069
mod - luamods/wolfadmin/auth/acl.lua Diff File
add - luamods/wolfadmin/commands/server/acl.lua Diff File
mod - luamods/wolfadmin/db/sqlite3.lua Diff File

WolfAdmin: develop/1.2.0 9012d54d

2017-01-21 12:16:26

Timo

Details Diff
Misc auth improvements (refs 0000069, 0000075)

* renamed methods to camelCase
* renamed methods to be more precise
* auth.isPlayerAllowed now returns boolean values
Affected Issues
0000069, 0000075
mod - luamods/wolfadmin/auth/acl.lua Diff File
mod - luamods/wolfadmin/auth/auth.lua Diff File
mod - luamods/wolfadmin/auth/shrubbot.lua Diff File
mod - luamods/wolfadmin/commands/admin/admintest.lua Diff File
mod - luamods/wolfadmin/commands/admin/ban.lua Diff File
mod - luamods/wolfadmin/commands/admin/gib.lua Diff File
mod - luamods/wolfadmin/commands/admin/help.lua Diff File
mod - luamods/wolfadmin/commands/admin/incognito.lua Diff File
mod - luamods/wolfadmin/commands/admin/kick.lua Diff File
mod - luamods/wolfadmin/commands/admin/listaliases.lua Diff File
mod - luamods/wolfadmin/commands/admin/listplayers.lua Diff File
mod - luamods/wolfadmin/commands/admin/mute.lua Diff File
mod - luamods/wolfadmin/commands/admin/plock.lua Diff File
mod - luamods/wolfadmin/commands/admin/put.lua Diff File
mod - luamods/wolfadmin/commands/admin/setlevel.lua Diff File
mod - luamods/wolfadmin/commands/admin/slap.lua Diff File
mod - luamods/wolfadmin/commands/admin/vmute.lua Diff File
mod - luamods/wolfadmin/commands/admin/warn.lua Diff File
mod - luamods/wolfadmin/commands/client/ac.lua Diff File
mod - luamods/wolfadmin/commands/commands.lua Diff File
mod - luamods/wolfadmin/game/voting.lua Diff File
mod - luamods/wolfadmin/players/greetings.lua Diff File

WolfAdmin: develop/1.2.0 e36d70ae

2017-01-21 12:19:07

Timo

Details Diff
Fixed minor rename issue caused by 9012d54da4aad7d6d5e62c101ee4e1b844699072 (refs 0000069, 0000075) Affected Issues
0000069, 0000075
mod - luamods/wolfadmin/auth/acl.lua Diff File

WolfAdmin: develop/1.2.0 7e5c0094

2017-01-21 16:06:25

Timo

Details Diff
Updated SQLite script with more levels and roles (refs 0000062, 0000069)

* also added transactions to improve performance
Affected Issues
0000062, 0000069
mod - database/new/wolfadmin_sqlite.sql Diff File
mod - luamods/wolfadmin/auth/auth.lua Diff File
mod - luamods/wolfadmin/auth/shrubbot.lua Diff File

WolfAdmin: develop/1.2.0 de27a417

2018-02-16 12:20:23

Timo

Details Diff
Fixed shrubbot flags for other mods (refs 0000046, 0000069, 0000062)

* changed !greeting flag from 'Q' to 'j' to maintain consistency across mods
* changed !cointoss flag to 'Z' so we do not take up another flag
* moved flags to separate files for each mod that includes shrubbot, autoloads on game init
Affected Issues
0000046, 0000062, 0000069
mod - luamods/wolfadmin/auth/auth.lua Diff File
mod - luamods/wolfadmin/auth/shrubbot.lua Diff File
add - luamods/wolfadmin/auth/shrubbot/etpub.lua Diff File
add - luamods/wolfadmin/auth/shrubbot/nq.lua Diff File
add - luamods/wolfadmin/auth/shrubbot/silent.lua Diff File

WolfAdmin: develop/1.2.0 44f78fb1

2018-12-31 11:03:48

Timo

Details Diff
ACL system improvements (refs 0000069)

* renamed 'roles' to 'permissions'
* added player permissions
* added functions to manipulate shrubbot files
Affected Issues
0000069
mod - database/new/mysql.sql Diff File
mod - database/new/sqlite.sql Diff File
mod - database/upgrade/1.1.0/mysql.sql Diff File
mod - database/upgrade/1.1.0/sqlite.sql Diff File
mod - luamods/wolfadmin/auth/acl.lua Diff File
mod - luamods/wolfadmin/auth/shrubbot.lua Diff File
mod - luamods/wolfadmin/commands/server/acl.lua Diff File
mod - luamods/wolfadmin/db/mysql.lua Diff File
mod - luamods/wolfadmin/db/sqlite3.lua Diff File

WolfAdmin: develop/1.2.0 b8688d7f

2018-12-31 11:17:26

Timo

Details Diff
Fixed !listplayers taking PERM_INCOGNITO into account (refs 0000062, 0000069) Affected Issues
0000062, 0000069
mod - luamods/wolfadmin/commands/admin/listplayers.lua Diff File

Issue History

Date Modified Username Field Change
2017-01-13 18:57 Timo New Issue
2017-01-13 18:57 Timo Relationship added child of 0000061
2017-01-13 18:58 Timo Assigned To => Timo
2017-01-13 18:58 Timo Status new => assigned
2017-01-13 18:58 Timo Relationship added related to 0000062
2017-01-20 19:54 Timo Changeset attached => WolfAdmin develop 702ed274
2017-01-21 12:16 Timo Changeset attached => WolfAdmin develop 9012d54d
2017-01-21 12:19 Timo Changeset attached => WolfAdmin develop e36d70ae
2017-01-21 16:15 Timo Changeset attached => WolfAdmin develop/1.2.0 7e5c0094
2018-02-13 10:45 Timo Status assigned => resolved
2018-02-13 10:45 Timo Fixed in Version => 1.2.0
2018-02-13 10:45 Timo Resolution open => fixed
2018-02-16 12:20 Timo Changeset attached => WolfAdmin develop/1.2.0 de27a417
2018-12-31 11:01 Changeset attached => WolfAdmin develop/1.2.0 44f78fb1
2018-12-31 11:13 Changeset attached => WolfAdmin develop/1.2.0 b8688d7f
2019-01-31 18:25 Timo Relationship added related to 0000097
2019-01-31 18:28 Timo Relationship added related to 0000092